ICBM Mod Installer for Minecraft 1.3.2 – Updated

As the name implies, the ICBM mod adds intercontinental ballistic missiles into Minecraft. But it’s not just as simple as that! This mod features different explosives, missiles and machines with three different tiers. If you like strategic warfare, blowing up things or watching your enemies burn under your carefully coordinated missile attacks, then this mod suits you. Perfectly.

This mod is made by Calclavia, all credit to modder. Please support the mod/ help the development and click this link (wait five seconds and click skip. no need to download mod).

ICBM is an add-on of Universal Electricity. It requires it to function (added by installer). However, there are some other mods out there that also use Universal Electricity. Universal Electricity is an API that ICBM uses.

Installer Requirements:

Windows PC – Currently only for Windows

.NET Framework 4.o (Most PC’s already have, but if it says you don’t then download here.)

Installer Instructions:

Before installing any mods to minecraft make sure to close minecraft.

Download one of the installers below (no difference they are same, just packed differently) Once downloaded, double click the installer and click “Install Mod”. When the installer is done it will display a message that the mod is installed. Then just close installer and start your minecraft. The mod has been Installed, you don’t have to do anything else.

If you are using windows 7 and get a message after using the installer that says “This program might not have installed correctly” this is nothing you can disable this message by using this file here.

If you get an error when using the exe version of the installer download the zip version below, extract the folder from the downloaded zip to desktop and run the installer from the extracted folder. Don’t remove it from the folder. You can also try running the installer as administrator if you are on windows 7.

Please Support the mod by downloading from the original mod thread here. And also read the Skydaz conditions.

Mod Version being installed: v0.5.4 for Minecraft 1.3.2

Mod Prerequisite Installed: FML (Forge ModLoader)

This mod adds FML (Forge Mod Loader). If you have ModLoader only mods installed then this will not be compatible. If you are not sure then install this mod on clean minecraft and don’t forget to clear mods folder. Any other install is not guaranteed. 

If you have the previous version installed please remove it from the mods folder before installing. Using the installer click on options then > minecraft folder then into mods and delete the old explosives + mod. Then install the mod.

Adfly Links: Any modder that want’s an installer for their mod and is hosted on Skydaz.com can have the installer downloads linked to their adfly or similar accounts. This way the modders do not loose out on traffic and can track their downloads. If you are a modder and want an installer for your mod + hosting on Skydaz then this can be set up for you.

DOWNLOADS

Download Mod from Mod Thread

Download Here .exe   (MD5: E7BB45CCCFE82DB00BED7D83F4A12B5A)

Download Here .zip     (MD5: 5F4A363672D5D74F25D438FA6A648E92)

PLEASE CREATE A BACKUP BEFORE INSTALLING ANY MODS – START WITH CLEAN MINECRAFT AND YOU WONT HAVE ANY ISSUES!!!  I AM NOT RESPONSIBLE FOR MESSED UP MINECRAFT. YOU HAVE BEEN WARNED.