Mo’Creatures Mod Installer for Minecraft 1.7.2 – Updated!

This Mod adds more creatures to the game. I’m sure everyone has heard or used Mo’Creatures before. This is one of the best additions one can add to minecraft, this mod adds a ton of mobs/animals. Checkout the original post for all the details.

This mod is made by DrZhark, all credit to modder. Please visit the original mod thread here for all info.

Installer Instructions:

The 1.6+ installers use the new minecraft launcher. If you have not used the new launcher yet, make sure to run the installer at least once. Log into minecraft and load the latest version/release. Then run installer and install the mod.

If you already have a modded profile/version, you can have the installer install it to that version. If you leave it set to “(Default)” then the installer will keep the default structure for installs and will only create a modded profile if one is not present. See “Default Mod Profile” below for the version of minecraft where this mod will install.

The installers will install all mods that use the same profile into the same mods folder/jar.
The installer only needs one default version of minecraft in the versions folder to install a mod.
If Forge/ModLoader is not present then installer by default will add a version of Forge/ModLoader this mod is compatible with.

Chagelog:

[6.2.0.dev.R2]
- fixed flying key not being able to be held.
- fixed many characters not being entered properly when trying to name a pet.
- fixed Komodo Dragons not spawning from pet amulets.
- fixed Komodo Dragon pet names showing up too high.
- refactored some canspawn check code.

[6.2.0.dev.R1 hotfix3]
- fixed new wyvern egg types not hatching.
- fixed pet scorpions not spawning from pet amulets.
- added PetScorpion to en_US lang file.

[6.2.0.dev.R1 hotfix2]
- fixed kittybed/fishbowl crash.

[6.2.0.dev.R1 hotfix1]
- fixed client crash when taming.

[6.2.0.dev.R1]
- update to MC 1.7.2

Internet Explorer users:

When downloading the .exe version of the installer, save the installer to a location like desktop, then run it. Do not run it straight from the browser, if you do you might get the “Skydaz Addons has stopped working”.

Mod Version: v6.2.0 Dev R2 for Minecraft 1.7.2

Mod Prerequisite: Forge

Mod Uninstall Option: Yes

Default Mod Profile: Forge

This mod uses Forge. The default setting will install mod and if not present, Forge to Forge profile. If you want the mod installed to another profile select the version using the installer and then install.

Please remember that you will need to clear the mods folder of ALL old version mods before installing the 1.7.2 mods. You can use the installer to clear the mods folder by clicking “Options”>”Clear Mods”

The latest 1.6.4 installers will downgrade any profile even a 1.7+ back to the 1.6.4 if one is needed..otherwise the 1.7+ will change 1.6.4 profiles to 1.7+ or vice versa…

To support development of this mod, the modders adfly links have been added to downloads.

DOWNLOADS

Download Mod from Original Thread

Download Here .zip (MD5: 63d45e63ba8332da216f563bff334a06) [drct]

Download Here .exe (MD5: bba9b6d3c2ea74a7c4a381e92cc3a46f) [drct]

PLEASE CREATE A BACKUP BEFORE INSTALLING ANY MODS – START WITH CLEAN MINECRAFT AND YOU WONT HAVE ANY ISSUES!!!  I AM NOT RESPONSIBLE FOR MESSED UP MINECRAFT. YOU HAVE BEEN WARNED.